Updated Audigy and X-Fi drivers for Windows 7

Daniel_K has released an updated driver package for the Audigy and X-Fi Soundblasters. The one key fix I've come across is CMSS now works on the Audigy 2 ZS.

Update for RC: These are what I'm using at the moment with my Audigy 2 ZS with the 7100 release candidate build:

Forum post.
Rapidshare download.
Filefront download.

MD5 hash: 16BEC9D7C047EF46DDA4F40AF1D47B1C.

Older drivers:

Audigy forum post.
RapidShare download.
MegaUpload download.

If you're downloading from elsewhere here's the MD5 hash: 66DA82FC18E49F3B32172A61BEDD0164.

X-Fi post.
RapidShare download.
MegaUpload download.

And here's the MD5 hash: 76CBA45C9DF761FFBC8BD61D17B3D127.

From my testing over the last few days the Auidgy works as well on Windows 7 as it does on Windows Vista.

7 comments

Comment from: Terry Day [Visitor]
Terry Day

Hi
I hope someone can help me,
Im running win vista 64bit ultimate edition and I am using a creative Audigy 2 zs soundblaster card,the sound I get in the game I plat (l4dead in steam)is fine the sound from my speakers is ok on surround sound but no matter what I do I cannot get clear voice audio in game (my friends say it sounds like I'm underwater!!)
i can see that my voice is being picked up by the mic in the properties window but it will not transmit clearly in game,will this driver pack help me ?or does anyone have ab idea what to do to fix this ?

I recently installed srs sandbox to see if that helped but to no avail.

Terry

02/10/09 @ 23:14
Comment from: m@verick [Visitor]
m@verick

newer driver from Daniel: http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&thread.id=135363

02/14/09 @ 16:55
Comment from: jorge [Visitor]
5 stars
jorge

Good Job ;)

05/09/09 @ 11:56
Comment from: Johndoe [Visitor]
Johndoe

Terry Day, the solution is to set your microphone configuration to the same specs as you have your sound card, example
if you're using 24bits, set it to 24bits 48000hz ( unless you're using 96000hz)
if not, it wont work, its very picky, sometimes you have to "force reset it". by setting first to the max value, getting in game, then quitting game, and then rechanging the options to the correct value of your card.

05/10/09 @ 03:04
Comment from: Bum Bandit Berry [Visitor]
3 stars
Bum Bandit Berry

you cheeseball m@verick, those are not for this audio card, they are for the value editions, not ZS. There is another pack with stolen drivers, icons, you name it by daniel of course (if you think he made them your a fool, they are ripped from creatives own installations, the only thing he did was change ini files, any noober can do it).

07/31/09 @ 23:53
Comment from: Adrian [Visitor]
Adrian

THANK YOU SO MUCH!!! - it worked perfectly! - I spent literally 7 hours looking and trying to fix it!

08/01/09 @ 04:48
Comment from: boris [Visitor]
boris

links are dead :(

03/16/13 @ 18:49